CVE-2023-46302

CVSS 3.1 Score 9.8 of 10 (high)

Details

Published Nov 20, 2023
Updated: Nov 30, 2023
CWE ID 502

Summary

CVE-2023-46302 is a vulnerability in Apache Submarine, specifically in the way it serializes against YAML. The bug is caused by snakeyaml. Apache Submarine uses JAXRS to define REST endpoints and has a YamlEntityProvider entity provider to handle YAML requests. However, the readFrom method in YamlUtils.java can be exploited through user-supplied data. This vulnerability affects Apache Submarine versions from 0.7.0 to 0.8.0, and users are advised to upgrade to version 0.8.0 or apply a cherry-pick fix if they cannot upgrade. The vulnerability has a base severity rating of CRITICAL and poses a high risk to organizations due to its potential impact on confidentiality, integrity, and availability of data and systems.

Explore Beyond the CVE Basics with Recorded Future's Vulnerability Intelligence

Note: This is just a basic overview providing quick insights into CVE-2023-46302 information. Gain full access to comprehensive CVE data, risk scores, prioritization, and mitigation data through Recorded Future's Vulnerability Intelligence:
  • Prioritize with Risk-Based Scoring
  • Explore the Extensive Vulnerability Database
  • Receive Early Alerts on Emerging CVEs
  • Focus on Critical Exploitable Vulnerabilities
  • Streamline Remediation with Integration Options