CVE-2023-46215

CVSS 3.1 Score 7.5 of 10 (high)

Details

Published Oct 28, 2023
Updated: Nov 8, 2023
CWE ID 532

Summary

CVE-2023-46215 is a vulnerability that affects Apache Airflow Celery provider versions 3.3.0 through 3.4.0 and Apache Airflow versions 1.10.0 through 2.6.3. It involves the insertion of sensitive information into log files when using rediss, amqp, or rpc protocols as Celery result backend. The vulnerability exposes clear text sensitive information in the logs, but does not provide direct access to the logs themselves. To remediate this issue, users are advised to upgrade Airflow Celery provider to version 3.4.1 and Apache Airflow to version 2.7.0, which includes the necessary fixes. The potential danger posed by this vulnerability lies in the exposure of confidential information that can be exploited by attackers if they gain unauthorized access to the log files.

Explore Beyond the CVE Basics with Recorded Future's Vulnerability Intelligence

Note: This is just a basic overview providing quick insights into CVE-2023-46215 information. Gain full access to comprehensive CVE data, risk scores, prioritization, and mitigation data through Recorded Future's Vulnerability Intelligence:
  • Prioritize with Risk-Based Scoring
  • Explore the Extensive Vulnerability Database
  • Receive Early Alerts on Emerging CVEs
  • Focus on Critical Exploitable Vulnerabilities
  • Streamline Remediation with Integration Options