CVE-2023-45827

CVSS 3.1 Score 7.3 of 10 (high)

Details

Published Nov 6, 2023
Updated: Nov 14, 2023
CWE ID 1321

Summary

A vulnerability with the CVE ID name CVE-2023-45827 has been identified in Dot Diver, a TypeScript utility library. Versions prior to 1.0.2 are affected by a Prototype Pollution vulnerability in the 'setByPath' function, which can lead to remote code execution (RCE). To remediate this vulnerability, users are advised to upgrade to release 1.0.2, which includes the necessary fix in commit '98daf567'. There are no known workarounds for this vulnerability. The potential danger posed by this vulnerability is high, with a base severity rating of HIGH and a base score of 7.3 according to the CVSS:3.1 vector string provided.

Explore Beyond the CVE Basics with Recorded Future's Vulnerability Intelligence

Note: This is just a basic overview providing quick insights into CVE-2023-45827 information. Gain full access to comprehensive CVE data, risk scores, prioritization, and mitigation data through Recorded Future's Vulnerability Intelligence:
  • Prioritize with Risk-Based Scoring
  • Explore the Extensive Vulnerability Database
  • Receive Early Alerts on Emerging CVEs
  • Focus on Critical Exploitable Vulnerabilities
  • Streamline Remediation with Integration Options