CVE-2023-45670

CVSS 3.1 Score 7.5 of 10 (high)

Details

Published Oct 30, 2023
Updated: Dec 13, 2023
CWE ID 352

Summary

CVE-2023-45670 is a vulnerability affecting Frigate, an open source network video recorder. Versions prior to 0.13.0 Beta 3 do not have CSRF protection for the config/save and config/set endpoints. This vulnerability allows an attacker to update the server configuration through a "drive-by" attack if they know specific information about a user's Frigate server and can trick an authenticated user into clicking a specially crafted link. The vulnerability poses a high risk as it can lead to arbitrary configuration changes. It has a base severity of HIGH and a base score of 7.5 according to the CVSS:3.1 vector string, indicating significant impact on integrity, confidentiality, and availability of the affected systems. The remediation for this vulnerability is to upgrade Frigate to version 0.13.0 Beta 3 or later to implement CSRF protection and prevent potential exploitation.

Explore Beyond the CVE Basics with Recorded Future's Vulnerability Intelligence

Note: This is just a basic overview providing quick insights into CVE-2023-45670 information. Gain full access to comprehensive CVE data, risk scores, prioritization, and mitigation data through Recorded Future's Vulnerability Intelligence:
  • Prioritize with Risk-Based Scoring
  • Explore the Extensive Vulnerability Database
  • Receive Early Alerts on Emerging CVEs
  • Focus on Critical Exploitable Vulnerabilities
  • Streamline Remediation with Integration Options