CVE-2023-45239

CVSS 3.1 Score 9.8 of 10 (high)

Details

Published Oct 6, 2023
Updated: Nov 7, 2023
CWE ID 790

Summary

CVE-2023-45239 is a cyber vulnerability that affects the product tac_plus prior to commit 4fdf178. It is characterized by a lack of input validation, which enables an attacker to inject shell commands and gain remote code execution on the tac_plus server. The vulnerability can be exploited when pre or post authentication commands are enabled, and it is important to note that the attacker needs control over the username, rem-addr, or NAC address sent to tac_plus. The severity of this vulnerability is classified as CRITICAL, with a base score of 9.8 out of 10. Remediation for this vulnerability should involve updating tac_plus to a version beyond commit 4fdf178 in order to address the input validation issue and prevent potential remote code execution attacks. Organizations should prioritize remediation due to the high impact on integrity and confidentiality if exploited.

Explore Beyond the CVE Basics with Recorded Future's Vulnerability Intelligence

Note: This is just a basic overview providing quick insights into CVE-2023-45239 information. Gain full access to comprehensive CVE data, risk scores, prioritization, and mitigation data through Recorded Future's Vulnerability Intelligence:
  • Prioritize with Risk-Based Scoring
  • Explore the Extensive Vulnerability Database
  • Receive Early Alerts on Emerging CVEs
  • Focus on Critical Exploitable Vulnerabilities
  • Streamline Remediation with Integration Options