CVSS 3.1 Score 5.4 of 10 (medium)


Published Nov 27, 2023
Updated: Dec 1, 2023


CVE-2023-43701 is a vulnerability that affects Apache Superset versions prior to 2.1.2. This vulnerability allows an authenticated malicious actor to store malicious code into Chart's metadata, which can be executed when a user accesses a specific deprecated API endpoint. To remediate this issue, users are advised to upgrade to version 2.1.2, which includes a fix for this vulnerability. The potential danger of this vulnerability lies in the possibility of an attacker injecting and executing malicious code within the organization's Apache Superset environment, potentially leading to unauthorized access or data manipulation.

Leverage our Vulnerability Intelligence module to secure your systems now - get detailed insights on CVE-2024-37364. Book your demo today.


Explore Beyond the CVE Basics with Recorded Future's Vulnerability Intelligence

Note: This is just a basic overview providing quick insights into CVE-2023-43701 information. Gain full access to comprehensive CVE data, risk scores, prioritization, and mitigation data through Recorded Future's Vulnerability Intelligence:
  • Prioritize with Risk-Based Scoring
  • Explore the Extensive Vulnerability Database
  • Receive Early Alerts on Emerging CVEs
  • Focus on Critical Exploitable Vulnerabilities
  • Streamline Remediation with Integration Options