CVE-2023-42792

CVSS 3.1 Score 6.5 of 10 (medium)

Details

Published Oct 14, 2023
Updated: Dec 21, 2023
CWE ID 668

Summary

CVE-2023-42792 is a security vulnerability in Apache Airflow versions prior to 2.7.2. It allows an authenticated user with limited access to craft a request that grants them write access to various DAG resources for DAGs they should not have access to, enabling them to clear those DAGs. The vulnerability poses a medium risk with a base severity score of 6.5. To mitigate the risk, users of Apache Airflow are strongly advised to upgrade to version 2.7.2 or newer.

Explore Beyond the CVE Basics with Recorded Future's Vulnerability Intelligence

Note: This is just a basic overview providing quick insights into CVE-2023-42792 information. Gain full access to comprehensive CVE data, risk scores, prioritization, and mitigation data through Recorded Future's Vulnerability Intelligence:
  • Prioritize with Risk-Based Scoring
  • Explore the Extensive Vulnerability Database
  • Receive Early Alerts on Emerging CVEs
  • Focus on Critical Exploitable Vulnerabilities
  • Streamline Remediation with Integration Options