CVE-2023-42501

CVSS 3.1 Score 4.3 of 10 (medium)

Details

Published Nov 27, 2023
Updated: Dec 1, 2023
CWE ID 276

Summary

CVE-2023-42501 is a cyber vulnerability that affects Apache Superset before version 2.1.2. It allows authenticated users to read CSS templates and annotations due to unnecessary read permissions within the Gamma role. To remediate this vulnerability, users should upgrade to version 2.1.2 or above and run `superset init` to reconstruct the Gamma role or remove the "can_read" permission from the affected resources. This vulnerability has a risk score of 10 and a base severity of MEDIUM, with a base score of 4.3 according to [email protected]. The potential danger it poses to organizations is low confidentiality impact but no integrity or availability impact, as indicated by the CVSS vector string: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N.

Share

Explore Beyond the CVE Basics with Recorded Future's Vulnerability Intelligence

Note: This is just a basic overview providing quick insights into CVE-2023-42501 information. Gain full access to comprehensive CVE data, risk scores, prioritization, and mitigation data through Recorded Future's Vulnerability Intelligence:
  • Prioritize with Risk-Based Scoring
  • Explore the Extensive Vulnerability Database
  • Receive Early Alerts on Emerging CVEs
  • Focus on Critical Exploitable Vulnerabilities
  • Streamline Remediation with Integration Options