CVE-2023-42454

CVSS 3.1 Score 10.0 of 10 (high)

Details

Published Sep 18, 2023
Updated: Sep 20, 2023
CWE ID 200

Summary

CVE-2023-42454 is a vulnerability affecting SQLPage versions prior to 0.11.1. This vulnerability allows an attacker to retrieve database connection information from SQLPage and connect directly to the database, if the SQLPage instance is publicly exposed, the database connection string is specified in the `sqlpage/sqlpage.json` configuration file (not in an environment variable), and the web_root is set as the current working directory. The issue can be remediated by updating to version 0.11.0 or later. Workarounds include using an environment variable instead of the configuration file to specify the database connection string and using a different web root that is not a parent of the SQLPage configuration directory. Organizations should also avoid exposing their database publicly to mitigate the potential danger posed by this vulnerability.

Share

Explore Beyond the CVE Basics with Recorded Future's Vulnerability Intelligence

Note: This is just a basic overview providing quick insights into CVE-2023-42454 information. Gain full access to comprehensive CVE data, risk scores, prioritization, and mitigation data through Recorded Future's Vulnerability Intelligence:
  • Prioritize with Risk-Based Scoring
  • Explore the Extensive Vulnerability Database
  • Receive Early Alerts on Emerging CVEs
  • Focus on Critical Exploitable Vulnerabilities
  • Streamline Remediation with Integration Options