CVE-2023-42442

CVSS 3.1 Score 8.2 of 10 (high)

Details

Published Sep 15, 2023
Updated: Sep 20, 2023
CWE ID 287

Summary

CVE-2023-42442 is a vulnerability affecting JumpServer, an open source bastion host and security audit system. Versions 3.0.0 to 3.5.5 and 3.6.4 are impacted, allowing session replays to be downloaded without authentication. However, session replays stored in cloud storage are not affected. The `/api/v1/terminal/sessions/` endpoint has broken permission controls, allowing anonymous access. Upgrading to versions 3.5.5 or 3.6.4 resolves the issue, and after the upgrade, visiting the API should return a 401 (not_authenticated) response code. This vulnerability has a high base severity score of 8.2 and poses a potential risk to organizations utilizing affected versions of JumpServer by allowing unauthorized access to session replays and potentially sensitive information.

Share

Explore Beyond the CVE Basics with Recorded Future's Vulnerability Intelligence

Note: This is just a basic overview providing quick insights into CVE-2023-42442 information. Gain full access to comprehensive CVE data, risk scores, prioritization, and mitigation data through Recorded Future's Vulnerability Intelligence:
  • Prioritize with Risk-Based Scoring
  • Explore the Extensive Vulnerability Database
  • Receive Early Alerts on Emerging CVEs
  • Focus on Critical Exploitable Vulnerabilities
  • Streamline Remediation with Integration Options