CVE-2023-42089

CVSS 3.1 Score 7.8 of 10 (high)

Details

Published May 3, 2024
Updated: May 23, 2024
CWE ID 416

Summary

CVE-2023-42089 is a vulnerability that affects Foxit PDF Reader. This vulnerability allows remote attackers to disclose sensitive information on affected installations. The flaw exists within the handling of templates and results from the lack of validating the existence of an object before performing operations on it. Exploiting this vulnerability requires user interaction, such as visiting a malicious page or opening a malicious file. It is possible for an attacker to leverage this vulnerability along with other vulnerabilities to execute arbitrary code in the current process context. The risk score for this vulnerability is 26, indicating a high potential danger to organizations using Foxit PDF Reader. To remediate this vulnerability, users should update to the latest version of Foxit PDF Reader as soon as it becomes available.

Leverage our Vulnerability Intelligence module to secure your systems now - get detailed insights on CVE-2024-37364. Book your demo today.

Share

Explore Beyond the CVE Basics with Recorded Future's Vulnerability Intelligence

Note: This is just a basic overview providing quick insights into CVE-2023-42089 information. Gain full access to comprehensive CVE data, risk scores, prioritization, and mitigation data through Recorded Future's Vulnerability Intelligence:
  • Prioritize with Risk-Based Scoring
  • Explore the Extensive Vulnerability Database
  • Receive Early Alerts on Emerging CVEs
  • Focus on Critical Exploitable Vulnerabilities
  • Streamline Remediation with Integration Options