CVE-2023-41890

CVSS 3.1 Score 7.5 of 10 (high)

Details

Published Sep 19, 2023
Updated: Dec 19, 2023
CWE ID 289
CWE ID 294

Summary

CVE-2023-41890 is a vulnerability affecting the Sustainsys.Saml2 library versions prior to 1.0.3 and 2.9.2, which adds SAML2P support to ASP.NET websites, allowing them to act as a SAML2 Service Provider. This vulnerability arises when the issuer of the Identity Provider is not adequately validated during response processing, enabling a malicious identity provider to create a Saml2 response that appears to be issued by another identity provider. It is also possible for an attacker to manipulate stored state intended for one identity provider when processing the response from another provider. Organizations relying on these features in their authentication/authorization logic are impacted, including those using the affected products: doqxFs, doqxFt, doqxFu, doqxFv, doqxFp, doqxFq, doqxFr, doqxF8, doqxF9, and more. The vulnerability has a base severity rating of HIGH with a CVSS score of 7.5 and an exploitability score of 3.9. To remediate this issue, upgrading to patched versions 1.0.3 or 2.9.2 is recommended; alternatively, the `AcsCommandResultCreated` notification can be utilized for validation if an upgrade is not feasible at the moment.

Leverage our Vulnerability Intelligence module to secure your systems now - get detailed insights on CVE-2024-37364. Book your demo today.

Share

Explore Beyond the CVE Basics with Recorded Future's Vulnerability Intelligence

Note: This is just a basic overview providing quick insights into CVE-2023-41890 information. Gain full access to comprehensive CVE data, risk scores, prioritization, and mitigation data through Recorded Future's Vulnerability Intelligence:
  • Prioritize with Risk-Based Scoring
  • Explore the Extensive Vulnerability Database
  • Receive Early Alerts on Emerging CVEs
  • Focus on Critical Exploitable Vulnerabilities
  • Streamline Remediation with Integration Options