CVSS 3.1 Score 9.8 of 10 (high)


Published Sep 25, 2023
Updated: Dec 8, 2023


CVE-2023-41419 is a critical cyber vulnerability that affects Gevent before version 23.9.0. This vulnerability allows a remote attacker to escalate privileges by exploiting a crafted script to the WSGIServer component. The National Vulnerability Database (NVD) rates the severity of this vulnerability as critical, with a base score of 9.8. The exploitability score is 3.9, indicating a medium level of difficulty for attackers to exploit this vulnerability. The impact of the vulnerability is significant, with high integrity and confidentiality impacts, as well as high availability impact. No user interaction or privileges are required for exploitation, and the attack vector is through the network. Organizations using affected versions of Gevent should update to version 23.9.0 or later to remediate this vulnerability and prevent potential escalation of privileges by remote attackers.

Leverage our Vulnerability Intelligence module to secure your systems now - get detailed insights on CVE-2024-37364. Book your demo today.


Explore Beyond the CVE Basics with Recorded Future's Vulnerability Intelligence

Note: This is just a basic overview providing quick insights into CVE-2023-41419 information. Gain full access to comprehensive CVE data, risk scores, prioritization, and mitigation data through Recorded Future's Vulnerability Intelligence:
  • Prioritize with Risk-Based Scoring
  • Explore the Extensive Vulnerability Database
  • Receive Early Alerts on Emerging CVEs
  • Focus on Critical Exploitable Vulnerabilities
  • Streamline Remediation with Integration Options