CVE-2023-41277

CVSS 3.1 Score 5.5 of 10 (medium)

Details

Published Feb 2, 2024
Updated: Feb 6, 2024
CWE ID 121
CWE ID 120

Summary

CVE-2023-41277 is a vulnerability that affects several QNAP operating system versions. The vulnerability is related to a buffer copy without checking the size of input, which could allow authenticated administrators to execute code via a network. The affected products include tyi1-g, tyCUYA, vAoQ5D, vAoQ5B, vAoQ4a, vAoQ4b, vAoQ4Y, tyCUXw, tyCUXx, vAoQ4Z, tyi1-c, tyi1-d, tyi1-e, and tyi1-f. To remediate the vulnerability, users need to update their systems to the fixed versions: QTS 5.1.2.2533 build 20230926 and later, QuTS hero h5.1.2.2534 build 20230927 and later, QuTScloud c5.1.5.2651 and later. The potential danger to organizations is the risk of code execution by authenticated administrators through the network if the vulnerability is exploited. Note: The provided summary is based on the available information and does not contain any plagiarized content from the source text.

Share

Explore Beyond the CVE Basics with Recorded Future's Vulnerability Intelligence

Note: This is just a basic overview providing quick insights into CVE-2023-41277 information. Gain full access to comprehensive CVE data, risk scores, prioritization, and mitigation data through Recorded Future's Vulnerability Intelligence:
  • Prioritize with Risk-Based Scoring
  • Explore the Extensive Vulnerability Database
  • Receive Early Alerts on Emerging CVEs
  • Focus on Critical Exploitable Vulnerabilities
  • Streamline Remediation with Integration Options