CVE-2023-41267

CVSS 3.1 Score 7.8 of 10 (high)

Details

Published Sep 14, 2023
Updated: Sep 19, 2023
CWE ID 829

Summary

CVE-2023-41267 is a vulnerability in the Apache Airflow HDFS Provider, affecting versions prior to 4.1.1. The vulnerability occurred due to an incorrect pip package installation being pointed out in the documentation, potentially allowing an attacker to claim and provide malicious code when the package is installed. The Airflow team has taken ownership of the package and fixed the issue in version 4.1.1, neutralizing the risk. The vulnerability has a high base severity and score of 7.8, with a potential impact on confidentiality and integrity being rated as high as well. It requires user interaction but has a low attack complexity and can be exploited locally. Organizations using affected versions should update to version 4.1.1 to remediate the vulnerability and mitigate potential dangers posed by exploitation of this vulnerability.

Leverage our Vulnerability Intelligence module to secure your systems now - get detailed insights on CVE-2024-37364. Book your demo today.

Share

Explore Beyond the CVE Basics with Recorded Future's Vulnerability Intelligence

Note: This is just a basic overview providing quick insights into CVE-2023-41267 information. Gain full access to comprehensive CVE data, risk scores, prioritization, and mitigation data through Recorded Future's Vulnerability Intelligence:
  • Prioritize with Risk-Based Scoring
  • Explore the Extensive Vulnerability Database
  • Receive Early Alerts on Emerging CVEs
  • Focus on Critical Exploitable Vulnerabilities
  • Streamline Remediation with Integration Options