CVSS 3.1 Score 6.3 of 10 (medium)


Published Nov 27, 2023
Updated: Jan 10, 2024
CWE ID 863


CVE-2023-40610 is a vulnerability that affects Apache Superset versions up to but excluding 2.1.2. It is categorized as an "Incorrect Authorization" vulnerability (CWE-863). The vulnerability allows an attacker to exploit improper authorization checks and potentially escalate privileges. By using a specially crafted CTE SQL statement, an attacker could change data on the metadata database, which can lead to tampering with the authentication/authorization data. The vulnerability has a base severity of MEDIUM and a base score of 6.3 according to the CVSS v3.1 rating. To remediate this vulnerability, users are advised to upgrade to a version higher than 2.1.2 to ensure that the issue is resolved and potential exploitation is mitigated.


Explore Beyond the CVE Basics with Recorded Future's Vulnerability Intelligence

Note: This is just a basic overview providing quick insights into CVE-2023-40610 information. Gain full access to comprehensive CVE data, risk scores, prioritization, and mitigation data through Recorded Future's Vulnerability Intelligence:
  • Prioritize with Risk-Based Scoring
  • Explore the Extensive Vulnerability Database
  • Receive Early Alerts on Emerging CVEs
  • Focus on Critical Exploitable Vulnerabilities
  • Streamline Remediation with Integration Options