CVE-2023-40567

CVSS 3.1 Score 6.5 of 10 (medium)

Details

Published Aug 31, 2023
Updated: Jan 12, 2024
CWE ID 787

Summary

CVE-2023-40567 is a vulnerability that affects FreeRDP, a free implementation of the Remote Desktop Protocol (RDP). The vulnerability is an Out-Of-Bounds Write in the `clear_decompress_bands_data` function, and it lacks offset validation. Exploiting this vulnerability could lead to an out of bounds write. The issue has been addressed in versions 2.11.0 and 3.0.0-beta3, so users are advised to upgrade to these versions. There are no known workarounds for this vulnerability. This vulnerability has a base severity of MEDIUM and a base score of 6.5 according to CVE's scoring system, indicating potential danger to organizations using the affected versions of FreeRDP.

Leverage our Vulnerability Intelligence module to secure your systems now - get detailed insights on CVE-2024-37364. Book your demo today.

Share

Explore Beyond the CVE Basics with Recorded Future's Vulnerability Intelligence

Note: This is just a basic overview providing quick insights into CVE-2023-40567 information. Gain full access to comprehensive CVE data, risk scores, prioritization, and mitigation data through Recorded Future's Vulnerability Intelligence:
  • Prioritize with Risk-Based Scoring
  • Explore the Extensive Vulnerability Database
  • Receive Early Alerts on Emerging CVEs
  • Focus on Critical Exploitable Vulnerabilities
  • Streamline Remediation with Integration Options