CVE-2023-40194

CVSS 3.1 Score 8.8 of 10 (high)

Details

Published Nov 27, 2023
Updated: Dec 1, 2023
CWE ID 610
CWE ID 73

Summary

CVE-2023-40194 is an arbitrary file creation vulnerability in Foxit Reader 12.1.3.15356's Javascript exportDataObject API, affecting the product Foxit Reader version 12.1.3.15356. This vulnerability occurs due to the mishandling of whitespace characters and can allow a specially crafted malicious file to create files at arbitrary locations, potentially leading to arbitrary code execution. The user needs to be tricked into opening the malicious file for the vulnerability to be triggered. Additionally, exploitation is possible if a user visits a specially crafted, malicious site with the browser plugin extension enabled. The vulnerability has a high base severity score of 8.8 and poses a potential risk to an organization's confidentiality and integrity, with an impact score of 5.9 out of 10. Note: The information provided is purely fictional and does not represent any real-world vulnerability or product.

Share

Explore Beyond the CVE Basics with Recorded Future's Vulnerability Intelligence

Note: This is just a basic overview providing quick insights into CVE-2023-40194 information. Gain full access to comprehensive CVE data, risk scores, prioritization, and mitigation data through Recorded Future's Vulnerability Intelligence:
  • Prioritize with Risk-Based Scoring
  • Explore the Extensive Vulnerability Database
  • Receive Early Alerts on Emerging CVEs
  • Focus on Critical Exploitable Vulnerabilities
  • Streamline Remediation with Integration Options