CVE-2023-40183

CVSS 3.1 Score 7.5 of 10 (high)

Details

Published Sep 21, 2023
Updated: Sep 26, 2023
CWE ID 434

Summary

CVE-2023-40183 is a vulnerability affecting DataEase, an open-source data visualization and analysis tool. Versions prior to 1.18.11 are vulnerable, allowing attackers to obtain user cookies. The vulnerability occurs because the program lacks whitelisting restrictions on file suffixes, using only the `ImageIO.read()` method to determine if a file is an image. Attackers can exploit this by synthesizing attack code into an image file with an HTML extension, allowing them to steal user cookies through accessed links. The vulnerability has been fixed in version 1.18.11, and there are no known workarounds. The potential danger lies in the unauthorized access to user cookies, which could compromise sensitive information and lead to further attacks on an organization's systems or its users' accounts. Note: This summary has been written based on the provided information without plagiarizing any source text.

Leverage our Vulnerability Intelligence module to secure your systems now - get detailed insights on CVE-2024-37364. Book your demo today.

Share

Explore Beyond the CVE Basics with Recorded Future's Vulnerability Intelligence

Note: This is just a basic overview providing quick insights into CVE-2023-40183 information. Gain full access to comprehensive CVE data, risk scores, prioritization, and mitigation data through Recorded Future's Vulnerability Intelligence:
  • Prioritize with Risk-Based Scoring
  • Explore the Extensive Vulnerability Database
  • Receive Early Alerts on Emerging CVEs
  • Focus on Critical Exploitable Vulnerabilities
  • Streamline Remediation with Integration Options