CVE-2023-40167

CVSS 3.1 Score 5.3 of 10 (medium)

Details

Published Sep 15, 2023
Updated: Oct 13, 2023
CWE ID 130

Summary

CVE-2023-40167 is a vulnerability in Jetty, a Java-based web server and servlet engine. Versions prior to 9.4.52, 10.0.16, 11.0.16, and 12.0.1 are affected by this vulnerability. The issue arises from Jetty accepting the "+" character following the content-length value in an HTTP/1 header field, which is more permissive than the standard allows. While there is no known exploit scenario, it is possible that request smuggling could occur if Jetty is used in combination with a server that does not close the connection after sending a 400 response to such requests. The recommended remediation is to update to versions 9.4.52, 10.0.16, 11.0.16, or 12.0.1 as they contain a patch for this issue.

Leverage our Vulnerability Intelligence module to secure your systems now - get detailed insights on CVE-2024-37364. Book your demo today.

Share

Explore Beyond the CVE Basics with Recorded Future's Vulnerability Intelligence

Note: This is just a basic overview providing quick insights into CVE-2023-40167 information. Gain full access to comprehensive CVE data, risk scores, prioritization, and mitigation data through Recorded Future's Vulnerability Intelligence:
  • Prioritize with Risk-Based Scoring
  • Explore the Extensive Vulnerability Database
  • Receive Early Alerts on Emerging CVEs
  • Focus on Critical Exploitable Vulnerabilities
  • Streamline Remediation with Integration Options