CVE-2023-39015

CVSS 3.1 Score 9.8 of 10 (high)

Details

Published Jul 28, 2023
Updated: Aug 3, 2023
CWE ID 94

Summary

The vulnerability with the CVE ID CVE-2023-39015 affects the webmagic-extension version 0.9.0 and below. It was discovered that there is a code injection vulnerability in the component us.codecraft.webmagic.downloader.PhantomJSDownloader. The vulnerability has a base severity rating of CRITICAL with a base score of 9.8 according to NIST. This means that it poses a high risk to organizations as it can be exploited remotely over a network without requiring any privileges or user interaction. The vulnerability has a high integrity impact and high confidentiality impact, potentially allowing an attacker to execute arbitrary code on the affected system and gain access to sensitive information. To remediate this vulnerability, users are advised to update their webmagic-extension version to a version above 0.9.0 where the issue has been fixed.

Leverage our Vulnerability Intelligence module to secure your systems now - get detailed insights on CVE-2024-37364. Book your demo today.

Share

Explore Beyond the CVE Basics with Recorded Future's Vulnerability Intelligence

Note: This is just a basic overview providing quick insights into CVE-2023-39015 information. Gain full access to comprehensive CVE data, risk scores, prioritization, and mitigation data through Recorded Future's Vulnerability Intelligence:
  • Prioritize with Risk-Based Scoring
  • Explore the Extensive Vulnerability Database
  • Receive Early Alerts on Emerging CVEs
  • Focus on Critical Exploitable Vulnerabilities
  • Streamline Remediation with Integration Options