CVE-2023-38428

CVSS 3.1 Score 9.1 of 10 (high)

Details

Published Jul 18, 2023
Updated: Dec 15, 2023
CWE ID 125

Summary

CVE-2023-38428 is a critical vulnerability found in the Linux kernel before version 6.3.4. The vulnerability affects various products, including ohMfk7, rh66fh, ohMfk6, rh66fg, and many others. It arises from a flaw in ksmbd's fs/ksmbd/smb2pdu.c file that fails to properly check the UserName value, resulting in an out-of-bounds read. The impact of this vulnerability is significant as it can lead to a high level of confidentiality compromise for organizations. To mitigate the risk, affected organizations should update their Linux kernel to version 6.3.4 or later as soon as possible.

Share

Explore Beyond the CVE Basics with Recorded Future's Vulnerability Intelligence

Note: This is just a basic overview providing quick insights into CVE-2023-38428 information. Gain full access to comprehensive CVE data, risk scores, prioritization, and mitigation data through Recorded Future's Vulnerability Intelligence:
  • Prioritize with Risk-Based Scoring
  • Explore the Extensive Vulnerability Database
  • Receive Early Alerts on Emerging CVEs
  • Focus on Critical Exploitable Vulnerabilities
  • Streamline Remediation with Integration Options