CVE-2023-37918

CVSS 3.1 Score 7.5 of 10 (high)

Details

Published Jul 21, 2023
Updated: Jul 31, 2023
CWE ID 287

Summary

CVE-2023-37918 is a vulnerability found in Dapr, a runtime for building distributed applications. This vulnerability allows bypassing API token authentication, which is used by the Dapr sidecar to authenticate calls from the application. Users who have configured API token authentication are affected. The vulnerability can be remediated by upgrading Dapr to versions 1.10.9 or 1.11.2. The danger posed by this vulnerability is high, as an attacker could craft a request that is always allowed by the Dapr sidecar over HTTP, even if the API token in the request is invalid or missing. This could lead to unauthorized access and potential security breaches for organizations using Dapr with API token authentication configured.

Share

Explore Beyond the CVE Basics with Recorded Future's Vulnerability Intelligence

Note: This is just a basic overview providing quick insights into CVE-2023-37918 information. Gain full access to comprehensive CVE data, risk scores, prioritization, and mitigation data through Recorded Future's Vulnerability Intelligence:
  • Prioritize with Risk-Based Scoring
  • Explore the Extensive Vulnerability Database
  • Receive Early Alerts on Emerging CVEs
  • Focus on Critical Exploitable Vulnerabilities
  • Streamline Remediation with Integration Options