CVE-2023-37900

CVSS 3.1 Score 2.7 of 10 (low)

Details

Published Jul 27, 2023
Updated: Aug 3, 2023
CWE ID 400
CWE ID 770

Summary

CVE-2023-37900 is a vulnerability affecting Crossplane, a framework for building cloud native control planes. Versions prior to 1.11.5, 1.12.3, and 1.13.0 are vulnerable, allowing a high-privileged user to create a Package referencing an arbitrarily large image that Crossplane would parse. This could lead to the exhaustion of available memory and the container being OOMKilled. The impact is limited due to the high privileges required and the eventually consistent nature of the controller. To remediate this vulnerability, organizations should update to versions 1.11.5, 1.12.3, or 1.13.0 of Crossplane. While the risk score is 5, indicating a moderate risk level, the base severity is rated as low with low availability impact and no confidentiality or integrity impact identified by [email protected] source.

Share

Explore Beyond the CVE Basics with Recorded Future's Vulnerability Intelligence

Note: This is just a basic overview providing quick insights into CVE-2023-37900 information. Gain full access to comprehensive CVE data, risk scores, prioritization, and mitigation data through Recorded Future's Vulnerability Intelligence:
  • Prioritize with Risk-Based Scoring
  • Explore the Extensive Vulnerability Database
  • Receive Early Alerts on Emerging CVEs
  • Focus on Critical Exploitable Vulnerabilities
  • Streamline Remediation with Integration Options