CVSS 3.1 Score 6.5 of 10 (medium)


Published Jul 12, 2023
Updated: Jul 20, 2023
CWE ID 863


CVE-2023-37579 is an Incorrect Authorization vulnerability in Apache Software Foundation Apache Pulsar Function Worker. This vulnerability affects Apache Pulsar versions before 2.10.4 and 2.11.0. It allows any authenticated user to access the configuration of a source or sink without authorization, potentially leading to leaked credentials as many configurations contain sensitive information. The vulnerability can be mitigated by upgrading the Pulsar Function Worker to a patched version: 2.10 users should upgrade to at least 2.10.4, and 2.11 users should upgrade to at least 2.11.1. Organizations running Pulsar Function Worker versions 2.9 and earlier should also upgrade to a newer version to address this issue. The potential danger of this vulnerability is high confidentiality impact, as it can expose sensitive information and credentials if exploited by an authenticated user with low privileges.

Leverage our Vulnerability Intelligence module to secure your systems now - get detailed insights on CVE-2024-37364. Book your demo today.


Explore Beyond the CVE Basics with Recorded Future's Vulnerability Intelligence

Note: This is just a basic overview providing quick insights into CVE-2023-37579 information. Gain full access to comprehensive CVE data, risk scores, prioritization, and mitigation data through Recorded Future's Vulnerability Intelligence:
  • Prioritize with Risk-Based Scoring
  • Explore the Extensive Vulnerability Database
  • Receive Early Alerts on Emerging CVEs
  • Focus on Critical Exploitable Vulnerabilities
  • Streamline Remediation with Integration Options