CVE-2023-37478

CVSS 3.1 Score 7.5 of 10 (high)

Details

Published Aug 1, 2023
Updated: Aug 4, 2023
CWE ID 284

Summary

CVE-2023-37478 is a vulnerability in the package manager pnpm. It allows for the construction of a tarball that appears safe when installed via npm or parsed by the registry, but becomes malicious when installed via pnpm due to how it parses tar archives. This means that a package that seems secure on the npm registry or when installed via npm could be replaced with a compromised or malicious version when installed via pnpm. The issue has been patched in versions 7.33.4 and 8.6.8 of pnpm. The vulnerability has a high severity rating and can potentially have a significant impact on the integrity and confidentiality of an organization's systems, making it important to update to the patched versions to mitigate the risk.

Share

Explore Beyond the CVE Basics with Recorded Future's Vulnerability Intelligence

Note: This is just a basic overview providing quick insights into CVE-2023-37478 information. Gain full access to comprehensive CVE data, risk scores, prioritization, and mitigation data through Recorded Future's Vulnerability Intelligence:
  • Prioritize with Risk-Based Scoring
  • Explore the Extensive Vulnerability Database
  • Receive Early Alerts on Emerging CVEs
  • Focus on Critical Exploitable Vulnerabilities
  • Streamline Remediation with Integration Options