CVE-2023-37471

CVSS 3.1 Score 9.1 of 10 (high)

Details

Published Jul 20, 2023
Updated: Jul 31, 2023
CWE ID 287

Summary

CVE-2023-37471 is a critical vulnerability affecting Open Access Management (OpenAM) up to version 14.7.2. It fails to properly validate the signature of SAML responses received during the SAMLv1.x Single Sign-On process, enabling attackers to impersonate any OpenAM user, including the administrator. A specially crafted SAML response sent to the SAMLPOSTProfileServlet servlet can exploit this vulnerability. The issue has been resolved in OpenAM 14.7.3-SNAPSHOT and later versions, but users who cannot upgrade should comment out the servlet from their pom file. This vulnerability poses a high danger to organizations as it allows unauthorized access and potential data breaches if exploited by malicious actors.

Leverage our Vulnerability Intelligence module to secure your systems now - get detailed insights on CVE-2024-37364. Book your demo today.

Share

Explore Beyond the CVE Basics with Recorded Future's Vulnerability Intelligence

Note: This is just a basic overview providing quick insights into CVE-2023-37471 information. Gain full access to comprehensive CVE data, risk scores, prioritization, and mitigation data through Recorded Future's Vulnerability Intelligence:
  • Prioritize with Risk-Based Scoring
  • Explore the Extensive Vulnerability Database
  • Receive Early Alerts on Emerging CVEs
  • Focus on Critical Exploitable Vulnerabilities
  • Streamline Remediation with Integration Options