CVE-2023-36810

CVSS Score of 10 (low)

Details

Published Jun 30, 2023
Updated: Jul 14, 2023
CWE ID 407

Summary

CVE-2023-36810 is a vulnerability in the pypdf library, which is a pure-python PDF library used for manipulating PDF files. This vulnerability allows an attacker to create a PDF file that triggers a long runtime, causing the current process to be blocked and utilizing 100% of a single CPU core. It does not affect memory usage. The issue has been addressed in PR 808, and versions from 1.27.9 onwards include the fix. Users are advised to upgrade to the patched version to mitigate this vulnerability. There are no known workarounds available. The potential danger posed by this vulnerability is rated as medium, with an exploitability score of 2.8 and a base severity score of 6.5 according to NVD/CVSS and [email protected] assessments.

Share

Explore Beyond the CVE Basics with Recorded Future's Vulnerability Intelligence

Note: This is just a basic overview providing quick insights into CVE-2023-36810 information. Gain full access to comprehensive CVE data, risk scores, prioritization, and mitigation data through Recorded Future's Vulnerability Intelligence:
  • Prioritize with Risk-Based Scoring
  • Explore the Extensive Vulnerability Database
  • Receive Early Alerts on Emerging CVEs
  • Focus on Critical Exploitable Vulnerabilities
  • Streamline Remediation with Integration Options