CVSS 3.1 Score 8.8 of 10 (high)


Published Jul 29, 2023
Updated: Aug 3, 2023


CVE-2023-36542 is a high-severity vulnerability that affects Apache NiFi versions 0.0.2 through 1.22.0. This vulnerability allows an authenticated and authorized user to configure a location that enables custom code execution through the use of HTTP URL references for retrieving drivers. To mitigate this vulnerability, it is recommended to upgrade to Apache NiFi version 1.23.0. The potential danger posed by this vulnerability is significant, as it allows privileged users to execute custom code, potentially leading to unauthorized access, data breaches, or other malicious activities within an organization's network infrastructure.

Leverage our Vulnerability Intelligence module to secure your systems now - get detailed insights on CVE-2024-37364. Book your demo today.


Explore Beyond the CVE Basics with Recorded Future's Vulnerability Intelligence

Note: This is just a basic overview providing quick insights into CVE-2023-36542 information. Gain full access to comprehensive CVE data, risk scores, prioritization, and mitigation data through Recorded Future's Vulnerability Intelligence:
  • Prioritize with Risk-Based Scoring
  • Explore the Extensive Vulnerability Database
  • Receive Early Alerts on Emerging CVEs
  • Focus on Critical Exploitable Vulnerabilities
  • Streamline Remediation with Integration Options