CVE-2023-36479

CVSS 3.1 Score 3.5 of 10 (low)

Details

Published Sep 15, 2023
Updated: Oct 16, 2023
CWE ID 149

Summary

CVE-2023-36479 is a vulnerability affecting Eclipse Jetty Canonical Repository. Specifically, the CgiServlet in Jetty can execute the wrong command if a user sends a request for a binary with a space in its name. This issue occurs when the servlet wraps the command in quotation marks and executes it through Runtime.exec, resulting in multiple tokens instead of one. The vulnerability was addressed in versions 9.4.52, 10.0.16, 11.0.16, and 12.0.0-beta2 of Jetty. The potential danger of this vulnerability lies in the possibility of attackers executing unintended commands on affected systems, which could lead to unauthorized access or other malicious activities.

Explore Beyond the CVE Basics with Recorded Future's Vulnerability Intelligence

Note: This is just a basic overview providing quick insights into CVE-2023-36479 information. Gain full access to comprehensive CVE data, risk scores, prioritization, and mitigation data through Recorded Future's Vulnerability Intelligence:
  • Prioritize with Risk-Based Scoring
  • Explore the Extensive Vulnerability Database
  • Receive Early Alerts on Emerging CVEs
  • Focus on Critical Exploitable Vulnerabilities
  • Streamline Remediation with Integration Options