CVE-2023-36459

CVSS 3.1 Score 9.3 of 10 (high)

Details

Published Jul 6, 2023
Updated: Jul 14, 2023
CWE ID 79

Summary

CVE-2023-36459 is a vulnerability that affects Mastodon, a free and open-source social network server based on ActivityPub. Versions 1.3 to 3.5.9, 4.0.5, and 4.1.3 of Mastodon are affected by this vulnerability, which allows an attacker to bypass HTML sanitization and include arbitrary HTML in oEmbed preview cards using carefully crafted oEmbed data. This introduces the risk of cross-site scripting (XSS) attacks when users click on preview cards for malicious links. Versions 3.5.9, 4.0.5, and 4.1.3 have been patched to address this issue, and organizations using affected versions should update to the patched versions immediately to mitigate the potential danger posed by this vulnerability. Note: The above report is a compilation of facts from the provided text and does not contain any personal opinions or biases.

Leverage our Vulnerability Intelligence module to secure your systems now - get detailed insights on CVE-2024-37364. Book your demo today.

Share

Explore Beyond the CVE Basics with Recorded Future's Vulnerability Intelligence

Note: This is just a basic overview providing quick insights into CVE-2023-36459 information. Gain full access to comprehensive CVE data, risk scores, prioritization, and mitigation data through Recorded Future's Vulnerability Intelligence:
  • Prioritize with Risk-Based Scoring
  • Explore the Extensive Vulnerability Database
  • Receive Early Alerts on Emerging CVEs
  • Focus on Critical Exploitable Vulnerabilities
  • Streamline Remediation with Integration Options