CVE-2023-36109

CVSS 3.1 Score 9.8 of 10 (high)

Details

Published Sep 20, 2023
Updated: Sep 22, 2023
CWE ID 120

Summary

CVE-2023-36109 is a Buffer Overflow vulnerability in JerryScript version 3.0, which allows remote attackers to execute arbitrary code through the ecma_stringbuilder_append_raw component at /jerry-core/ecma/base/ecma-helpers-string.c. The vulnerability affects the product 'sv5o6t'. To remediate this vulnerability, users should update their JerryScript installation to a version that is not affected. This vulnerability has a high severity rating with a base score of 9.8 out of 10, indicating that it poses a critical danger to organizations. The exploitability score is 3.9 out of 10, suggesting that it is moderately difficult to exploit. The impact includes high integrity and confidentiality impacts, as well as high availability impact.

Explore Beyond the CVE Basics with Recorded Future's Vulnerability Intelligence

Note: This is just a basic overview providing quick insights into CVE-2023-36109 information. Gain full access to comprehensive CVE data, risk scores, prioritization, and mitigation data through Recorded Future's Vulnerability Intelligence:
  • Prioritize with Risk-Based Scoring
  • Explore the Extensive Vulnerability Database
  • Receive Early Alerts on Emerging CVEs
  • Focus on Critical Exploitable Vulnerabilities
  • Streamline Remediation with Integration Options