CVE-2023-35944

CVSS 3.1 Score 8.2 of 10 (high)

Details

Published Jul 25, 2023
Updated: Aug 2, 2023
CWE ID 444
CWE ID 20

Summary

CVE-2023-35944 is a vulnerability affecting Envoy, an open source edge and service proxy used for cloud-native applications. Prior to versions 1.27.0, 1.26.4, 1.25.9, 1.24.10, and 1.23.12, Envoy allowed mixed-case schemes in HTTP/2 but had case-sensitive internal scheme checks, which could lead to the rejection of requests with mixed-case schemes or the bypassing of some requests in unencrypted connections. However, with the fix in the mentioned versions, Envoy now lowercases scheme values by default and changes the case-sensitive internal scheme checks to be case-insensitive. There are no known workarounds for this vulnerability, which has a base severity of HIGH and can potentially pose a danger to organizations by impacting the confidentiality of data in affected products using Envoy as a proxy for their cloud-native applications. Note: This summary is based on the provided information and does not contain any personal opinions or biases.

Share

Explore Beyond the CVE Basics with Recorded Future's Vulnerability Intelligence

Note: This is just a basic overview providing quick insights into CVE-2023-35944 information. Gain full access to comprehensive CVE data, risk scores, prioritization, and mitigation data through Recorded Future's Vulnerability Intelligence:
  • Prioritize with Risk-Based Scoring
  • Explore the Extensive Vulnerability Database
  • Receive Early Alerts on Emerging CVEs
  • Focus on Critical Exploitable Vulnerabilities
  • Streamline Remediation with Integration Options