CVE-2023-35887

CVSS 3.1 Score 4.3 of 10 (medium)

Details

Published Jul 10, 2023
Updated: Nov 21, 2023
CWE ID 22

Summary

CVE-2023-35887 is a vulnerability that exposes sensitive information to an unauthorized actor in Apache Software Foundation Apache MINA. This vulnerability affects Apache MINA versions 1.0 to 2.10. Users are advised to upgrade to version 2.10 to remediate this issue. The vulnerability allows logged users in SFTP servers implemented using Apache MINA SSHD to discover information about items outside the rooted tree through parent navigation or involving symlinks. The potential danger of this vulnerability is considered medium, with a base severity score of 4.3, and it has a low impact on confidentiality.

Share

Explore Beyond the CVE Basics with Recorded Future's Vulnerability Intelligence

Note: This is just a basic overview providing quick insights into CVE-2023-35887 information. Gain full access to comprehensive CVE data, risk scores, prioritization, and mitigation data through Recorded Future's Vulnerability Intelligence:
  • Prioritize with Risk-Based Scoring
  • Explore the Extensive Vulnerability Database
  • Receive Early Alerts on Emerging CVEs
  • Focus on Critical Exploitable Vulnerabilities
  • Streamline Remediation with Integration Options