CVE-2023-3550

CVSS 3.1 Score 7.3 of 10 (high)

Details

Published Sep 25, 2023
Updated: Feb 1, 2024
CWE ID 79

Summary

CVE-2023-3550 is a vulnerability affecting Mediawiki v1.40.0. This vulnerability occurs when the instance administrator allows XML file uploads without validating namespaces used in the XML files. As a result, a remote attacker with a low-privileged user account can exploit this vulnerability by sending a malicious link to the instance administrator, allowing them to become an administrator. The severity of this vulnerability is classified as high, with a base score of 7.3 according to CVSS:3.1. The potential danger it poses to an organization includes the compromise of integrity and confidentiality, with no impact on availability. To remediate this vulnerability, it is recommended to validate namespaces in XML files before allowing uploads and applying any available patches or updates provided by Mediawiki.

Share

Explore Beyond the CVE Basics with Recorded Future's Vulnerability Intelligence

Note: This is just a basic overview providing quick insights into CVE-2023-3550 information. Gain full access to comprehensive CVE data, risk scores, prioritization, and mitigation data through Recorded Future's Vulnerability Intelligence:
  • Prioritize with Risk-Based Scoring
  • Explore the Extensive Vulnerability Database
  • Receive Early Alerts on Emerging CVEs
  • Focus on Critical Exploitable Vulnerabilities
  • Streamline Remediation with Integration Options