CVE-2023-35167

CVSS Score of 10 (low)

Details

Published Jun 23, 2023
Updated: Jul 5, 2023
CWE ID 284

Summary

CVE-2023-35167, also known as the "Improper Access Control" vulnerability, affects Remult, a CRUD framework for full-stack TypeScript. By using the apiPrefilter option of the @Entity decorator and setting it to a function that returns a filter preventing unauthorized access to data, an attacker who knows the id of an entity instance can gain unauthorized read, update, and delete access to it. The vulnerability has been fixed in version 0.20.6. As a workaround, users can set the apiPrefilter option to a filter object instead of a function. This vulnerability poses a medium risk with low privileges required and no user interaction necessary for exploitation. The potential impact includes low integrity and confidentiality impacts but could lead to unauthorized access to sensitive data.

Share

Explore Beyond the CVE Basics with Recorded Future's Vulnerability Intelligence

Note: This is just a basic overview providing quick insights into CVE-2023-35167 information. Gain full access to comprehensive CVE data, risk scores, prioritization, and mitigation data through Recorded Future's Vulnerability Intelligence:
  • Prioritize with Risk-Based Scoring
  • Explore the Extensive Vulnerability Database
  • Receive Early Alerts on Emerging CVEs
  • Focus on Critical Exploitable Vulnerabilities
  • Streamline Remediation with Integration Options