CVE-2023-35131

CVSS Score of 10 (low)

Details

Published Jun 22, 2023
Updated: Apr 19, 2024
CWE ID 79

Summary

CVE-2023-35131 is a vulnerability that affects Moodle versions 4.2, 4.1 to 4.1.3, 4.0 to 4.0.8, and 3.11 to 3.11.14, specifically on the groups page where additional sanitizing is needed to prevent an XSS risk. This vulnerability has a CVSS score of 6.1, indicating a medium severity level. The affected products include various versions of Moodle, such as k19XE8, k19XE9, otXWge, and mklBxJ among others. To remediate this vulnerability, organizations using affected versions of Moodle should apply the necessary updates or patches provided by the vendor to ensure proper sanitization of content and mitigate the XSS risk it poses. If exploited, this vulnerability could allow an attacker to inject malicious code into webpages viewed by users on the affected Moodle instances potentially leading to unauthorized access or data theft within an organization's environment.

Share

Explore Beyond the CVE Basics with Recorded Future's Vulnerability Intelligence

Note: This is just a basic overview providing quick insights into CVE-2023-35131 information. Gain full access to comprehensive CVE data, risk scores, prioritization, and mitigation data through Recorded Future's Vulnerability Intelligence:
  • Prioritize with Risk-Based Scoring
  • Explore the Extensive Vulnerability Database
  • Receive Early Alerts on Emerging CVEs
  • Focus on Critical Exploitable Vulnerabilities
  • Streamline Remediation with Integration Options