CVE-2023-34253

CVSS Score of 10 (low)

Details

Published Jun 14, 2023
Updated: Nov 7, 2023
CWE ID 94
CWE ID 1336
CWE ID 184

Summary

CVE-2023-34253 is a vulnerability affecting Grav, a flat-file content management system. Prior to version 1.7.42, the denylist implemented in commit 9d6a2d to prevent the execution of dangerous functions through malicious templates was inadequate and could be easily bypassed in multiple ways. This vulnerability allows a low privileged attacker with login access to the Grav Admin panel and page creation/update permissions to inject malicious templates and achieve remote code execution. The issue has been addressed in version 1.7.42 with an improved denylist. The vulnerability has a high severity rating given its potential impact on confidentiality, integrity, and availability of affected systems.

Share

Explore Beyond the CVE Basics with Recorded Future's Vulnerability Intelligence

Note: This is just a basic overview providing quick insights into CVE-2023-34253 information. Gain full access to comprehensive CVE data, risk scores, prioritization, and mitigation data through Recorded Future's Vulnerability Intelligence:
  • Prioritize with Risk-Based Scoring
  • Explore the Extensive Vulnerability Database
  • Receive Early Alerts on Emerging CVEs
  • Focus on Critical Exploitable Vulnerabilities
  • Streamline Remediation with Integration Options