CVE-2023-34047

CVSS 3.1 Score 3.1 of 10 (low)

Details

Published Sep 20, 2023
Updated: Oct 18, 2023

Summary

CVE-2023-34047 is a vulnerability affecting Spring for GraphQL versions 1.1.0 - 1.1.5 and 1.2.0 - 1.2.2, where a batch loader function may be exposed to GraphQL context values from a different session, including security context values. This vulnerability occurs when an application provides a DataLoaderOptions instance while registering batch loader functions through DefaultBatchLoaderRegistry. The affected products include 'tz88oo', 'tz88op', 'tz88oq', 'tz88or', 'tz88os', 'tz88ot', 'tz88oh', 'tz88oi', 'tz88oj', 'tz88ok', 'tz88ol', and 'tz88om'. The risk score is 5, the base severity is low, and the base score is 3.1 according to security@vmware.com.

Explore Beyond the CVE Basics with Recorded Future's Vulnerability Intelligence

Note: This is just a basic overview providing quick insights into CVE-2023-34047 information. Gain full access to comprehensive CVE data, risk scores, prioritization, and mitigation data through Recorded Future's Vulnerability Intelligence:
  • Prioritize with Risk-Based Scoring
  • Explore the Extensive Vulnerability Database
  • Receive Early Alerts on Emerging CVEs
  • Focus on Critical Exploitable Vulnerabilities
  • Streamline Remediation with Integration Options