CVE-2023-34035

CVSS 3.1 Score 5.3 of 10 (medium)

Details

Published Jul 18, 2023
Updated: Jul 27, 2023
CWE ID 863

Summary

CVE-2023-34035 is a vulnerability that affects Spring Security versions 5.8 prior to 5.8.5, 6.0 prior to 6.0.5, and 6.1 prior to 6.1.2. It could potentially be exploited through an authorization rule misconfiguration if the application uses requestMatchers(String) and multiple servlets, with one of them being Spring MVC's DispatcherServlet. This vulnerability occurs when Spring MVC is on the classpath, Spring Security secures more than one servlet in a single application (including DispatcherServlet), and the application uses requestMatchers(String) to refer to endpoints that are not Spring MVC endpoints. To remediate this vulnerability, organizations should upgrade to Spring Security versions 5.8.5, 6.0.5, or 6.1.2 or later versions that address this issue. Failure to mitigate this vulnerability could lead to unauthorized access and potential security breaches within the affected organization's system.

Share

Explore Beyond the CVE Basics with Recorded Future's Vulnerability Intelligence

Note: This is just a basic overview providing quick insights into CVE-2023-34035 information. Gain full access to comprehensive CVE data, risk scores, prioritization, and mitigation data through Recorded Future's Vulnerability Intelligence:
  • Prioritize with Risk-Based Scoring
  • Explore the Extensive Vulnerability Database
  • Receive Early Alerts on Emerging CVEs
  • Focus on Critical Exploitable Vulnerabilities
  • Streamline Remediation with Integration Options