CVE-2023-33202

CVSS 3.1 Score 5.5 of 10 (medium)

Details

Published Nov 23, 2023
Updated: Jan 25, 2024
CWE ID 400

Summary

CVE-2023-33202 is a vulnerability that affects Bouncy Castle for Java versions before 1.73. The vulnerability is found in the org.bouncycastle.openssl.PEMParser class, which parses OpenSSL PEM encoded streams containing X.509 certificates, PKCS8 encoded keys, and PKCS7 objects. Exploiting this vulnerability can cause an OutOfMemoryError, leading to a potential Denial of Service (DoS) attack. Users of the FIPS Java API before version 1.0.2.4 are also affected. To remediate the issue, organizations should update to Bouncy Castle for Java version 1.73 or later. The vulnerability has a base severity of MEDIUM and an exploitability score of 1.8 out of 10 according to [email protected]'s rating, with a potential high impact on availability.

Share

Explore Beyond the CVE Basics with Recorded Future's Vulnerability Intelligence

Note: This is just a basic overview providing quick insights into CVE-2023-33202 information. Gain full access to comprehensive CVE data, risk scores, prioritization, and mitigation data through Recorded Future's Vulnerability Intelligence:
  • Prioritize with Risk-Based Scoring
  • Explore the Extensive Vulnerability Database
  • Receive Early Alerts on Emerging CVEs
  • Focus on Critical Exploitable Vulnerabilities
  • Streamline Remediation with Integration Options