CVE-2023-31431

CVSS 3.1 Score 5.5 of 10 (medium)

Details

Published Aug 2, 2023
Updated: Dec 21, 2023
CWE ID 120

Summary

CVE-2023-31431 is a buffer overflow vulnerability in the "diagstatus" command in Brocade Fabric OS before Brocade Fabric v9.2.0 and v9.1.1c. This vulnerability could be exploited by an authenticated user, potentially leading to a denial of service by crashing the Brocade Fabric OS switch. The affected products are those running on Brocade Fabric OS versions prior to v9.2.0 and v9.1.1c. To remediate this vulnerability, organizations should upgrade their Brocade Fabric OS to version 9.2.0 or later. The potential danger posed by this vulnerability is a disruption of service and potential impact on network availability for affected organizations using vulnerable versions of Brocade Fabric OS switches.

Share

Explore Beyond the CVE Basics with Recorded Future's Vulnerability Intelligence

Note: This is just a basic overview providing quick insights into CVE-2023-31431 information. Gain full access to comprehensive CVE data, risk scores, prioritization, and mitigation data through Recorded Future's Vulnerability Intelligence:
  • Prioritize with Risk-Based Scoring
  • Explore the Extensive Vulnerability Database
  • Receive Early Alerts on Emerging CVEs
  • Focus on Critical Exploitable Vulnerabilities
  • Streamline Remediation with Integration Options