CVE-2023-3110

CVSS Score of 10 (low)

Details

Published Jun 21, 2023
Updated: Jun 28, 2023
CWE ID 119
CWE ID 120

Summary

CVE-2023-3110 is a vulnerability in SiLabs Unify Gateway 1.3.1 and earlier versions, which allows an unauthenticated attacker within Z-Wave range to overflow a stack buffer, resulting in arbitrary code execution. This vulnerability has a CVSS score of 9.6 (Critical) according to [email protected] and 8.8 (High) according to [email protected]. It has a high impact on integrity and confidentiality, as well as availability. The vulnerability is categorized as CWE-119 (Improper Restriction of Operations within the Bounds of a Memory Buffer) and CWE-120 (BUFFER COPY WITHOUT CHECKING SIZE OF INPUT ('CLASSIC BUFFER OVERFLOW')). Remediation for this vulnerability is not specified, but it is crucial for organizations using SiLabs Unify Gateway 1.3.1 or earlier versions to apply any available security patches promptly to mitigate the potential danger posed by arbitrary code execution.

Leverage our Vulnerability Intelligence module to secure your systems now - get detailed insights on CVE-2024-37364. Book your demo today.

Share

Explore Beyond the CVE Basics with Recorded Future's Vulnerability Intelligence

Note: This is just a basic overview providing quick insights into CVE-2023-3110 information. Gain full access to comprehensive CVE data, risk scores, prioritization, and mitigation data through Recorded Future's Vulnerability Intelligence:
  • Prioritize with Risk-Based Scoring
  • Explore the Extensive Vulnerability Database
  • Receive Early Alerts on Emerging CVEs
  • Focus on Critical Exploitable Vulnerabilities
  • Streamline Remediation with Integration Options