CVSS 3.1 Score 0.0 of 10 (low)


Published Jul 12, 2023
Updated: Jul 20, 2023
CWE ID 287


CVE-2023-31007 is an Improper Authentication vulnerability in Apache Pulsar Broker that allows a client to stay connected to a broker after authentication data expires. This vulnerability affects Apache Pulsar versions through 2.9.4, 2.10.0 through 2.10.3, and 2.11.0. To remediate the issue, users of Pulsar Broker should upgrade to the patched versions: 2.9 users should upgrade to at least 2.9.5, 2.10 users should upgrade to at least 2.10.4, and 2.11 users should upgrade to at least 2.11.1. The potential danger of this vulnerability lies in unauthorized access and potential exploitation of the Apache Pulsar Broker by an attacker who could remain connected even after authentication data has expired, compromising the security of an organization's infrastructure and data.

Leverage our Vulnerability Intelligence module to secure your systems now - get detailed insights on CVE-2024-37364. Book your demo today.


Explore Beyond the CVE Basics with Recorded Future's Vulnerability Intelligence

Note: This is just a basic overview providing quick insights into CVE-2023-31007 information. Gain full access to comprehensive CVE data, risk scores, prioritization, and mitigation data through Recorded Future's Vulnerability Intelligence:
  • Prioritize with Risk-Based Scoring
  • Explore the Extensive Vulnerability Database
  • Receive Early Alerts on Emerging CVEs
  • Focus on Critical Exploitable Vulnerabilities
  • Streamline Remediation with Integration Options