CVE-2023-2638

CVSS Score of 10 (low)

Details

Published Jun 13, 2023
Updated: Jun 26, 2023
CWE ID 287

Summary

CVE-2023-2638: Rockwell Automation's FactoryTalk System Services has a vulnerability where it does not verify if a backup configuration archive is password protected. This can lead to improper authorization and the loading of malicious configuration archives. The vulnerability affects the FTSSBackupRestore.exe component. An authenticated non-admin user can exploit this vulnerability by creating a malicious backup archive without password protection, which will be accepted as a valid backup during a restore procedure. User interaction is required for successful exploitation. The risk score for this vulnerability is 26, indicating a medium risk. To remediate the issue, users should ensure that all backup configuration archives are password protected to prevent unauthorized access and manipulation. This vulnerability poses a potential danger to organizations as it allows an attacker with local access to compromise the integrity of the FactoryTalk System Services and potentially disrupt operations or gain unauthorized access to sensitive information.

Share

Explore Beyond the CVE Basics with Recorded Future's Vulnerability Intelligence

Note: This is just a basic overview providing quick insights into CVE-2023-2638 information. Gain full access to comprehensive CVE data, risk scores, prioritization, and mitigation data through Recorded Future's Vulnerability Intelligence:
  • Prioritize with Risk-Based Scoring
  • Explore the Extensive Vulnerability Database
  • Receive Early Alerts on Emerging CVEs
  • Focus on Critical Exploitable Vulnerabilities
  • Streamline Remediation with Integration Options