CVE-2023-26153

CVSS 3.1 Score 8.3 of 10 (high)

Details

Published Oct 6, 2023
Updated: Nov 7, 2023
CWE ID 78
CWE ID 502

Summary

CVE-2023-26153 is a vulnerability that affects versions of the geokit-rails package prior to 2.5.0. This vulnerability is classified as Command Injection and is caused by unsafe deserialization of YAML within the 'geo_location' cookie. It can be exploited remotely through a malicious cookie value, allowing an attacker to execute commands on the host system. The affected products include 'tCwJYf', 'tCwJYe', 'tCwJYd', 'tCwJYc', 'tCwJYj', 'tCwJYi', 'tCwJYh', and 'tCwJYg'. To remediate this vulnerability, users should update to version 2.5.0 or newer of the geokit-rails package. This vulnerability poses a high risk to organizations as it allows unauthorized remote command execution on affected systems, potentially leading to data breaches or system compromise.

Explore Beyond the CVE Basics with Recorded Future's Vulnerability Intelligence

Note: This is just a basic overview providing quick insights into CVE-2023-26153 information. Gain full access to comprehensive CVE data, risk scores, prioritization, and mitigation data through Recorded Future's Vulnerability Intelligence:
  • Prioritize with Risk-Based Scoring
  • Explore the Extensive Vulnerability Database
  • Receive Early Alerts on Emerging CVEs
  • Focus on Critical Exploitable Vulnerabilities
  • Streamline Remediation with Integration Options