CVSS 3.1 Score 6.5 of 10 (medium)


Published Sep 19, 2023
Updated: Nov 7, 2023


CVE-2023-26143 is a vulnerability affecting versions of the package blamer before 1.0.4. The vulnerability allows for Arbitrary Argument Injection via the blameByFile() API, as the library does not properly sanitize user input or validate file paths. Additionally, it fails to pass command-line flags to the git binary using double-dash POSIX characters (--), which indicates the end of options. This vulnerability has a base severity rating of MEDIUM with a base score of 6.5 according to CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:L. The potential danger it poses to an organization is low integrity impact and no confidentiality impact, but it can still be exploited remotely without requiring privileges or user interaction. To remediate this vulnerability, users should update to version 1.0.4 or later of the blamer package.

Explore Beyond the CVE Basics with Recorded Future's Vulnerability Intelligence

Note: This is just a basic overview providing quick insights into CVE-2023-26143 information. Gain full access to comprehensive CVE data, risk scores, prioritization, and mitigation data through Recorded Future's Vulnerability Intelligence:
  • Prioritize with Risk-Based Scoring
  • Explore the Extensive Vulnerability Database
  • Receive Early Alerts on Emerging CVEs
  • Focus on Critical Exploitable Vulnerabilities
  • Streamline Remediation with Integration Options