CVE-2023-2585

CVSS Score of 10 (low)

Details

Published Dec 21, 2023
Updated: Jan 2, 2024
CWE ID 358

Summary

CVE-2023-2585: Keycloak's device authorization grant vulnerability affects multiple products including t4UgoI, r_8Qio, t4UgoN, r_8Qiv, t4UgoM, r6Wi72, svPGdd, aZdyla, r_8Qin, r_8Qim, r_8Qil, and qsg5em. The vulnerability allows an attacker client to exploit missing validation and trick an authorization admin into granting consent to a malicious OAuth client or unauthorized access to an existing OAuth client. This poses a high risk with a CVSS base score of 8.1 out of 10. To remediate this vulnerability, organizations should update their Keycloak installation to the latest version that includes the fix for this issue.

Share

Explore Beyond the CVE Basics with Recorded Future's Vulnerability Intelligence

Note: This is just a basic overview providing quick insights into CVE-2023-2585 information. Gain full access to comprehensive CVE data, risk scores, prioritization, and mitigation data through Recorded Future's Vulnerability Intelligence:
  • Prioritize with Risk-Based Scoring
  • Explore the Extensive Vulnerability Database
  • Receive Early Alerts on Emerging CVEs
  • Focus on Critical Exploitable Vulnerabilities
  • Streamline Remediation with Integration Options