CVE-2023-25499

CVSS Score of 10 (low)

Details

Published Jun 22, 2023
Updated: Jun 30, 2023
CWE ID 200

Summary

CVE-2023-25499 is a vulnerability that affects Vaadin versions 10.0.0 through 10.0.22, 11.0.0 through 14.10.0, 15.0.0 through 22.0.28, 23.0.0 through 23.3.12, 24.0.0 through 24.0.5, and 24.1.0.alpha1 to 24.1.beta1, allowing potential information disclosure when adding non-visible components to the UI on the server side of the application's content delivery to the browser in Vaadin web framework products. The vulnerability has a CVSS score of 5.7 (medium severity) and can be remediated by updating to the latest version of Vaadin that addresses the issue, which is recommended to prevent potential confidentiality impact on organizations using affected versions of Vaadin in their web applications. Note: The summary provided above is based on the information given and does not include any analysis or interpretation by the cyber-security analyst.

Leverage our Vulnerability Intelligence module to secure your systems now - get detailed insights on CVE-2024-37364. Book your demo today.

Share

Explore Beyond the CVE Basics with Recorded Future's Vulnerability Intelligence

Note: This is just a basic overview providing quick insights into CVE-2023-25499 information. Gain full access to comprehensive CVE data, risk scores, prioritization, and mitigation data through Recorded Future's Vulnerability Intelligence:
  • Prioritize with Risk-Based Scoring
  • Explore the Extensive Vulnerability Database
  • Receive Early Alerts on Emerging CVEs
  • Focus on Critical Exploitable Vulnerabilities
  • Streamline Remediation with Integration Options