CVE-2023-2449

CVSS 3.1 Score 9.8 of 10 (high)

Details

Published Nov 22, 2023
Updated: Dec 4, 2023

Summary

The UserPro plugin for WordPress, up to and including version 5.1.1, is vulnerable to unauthorized password resets (CVE-2023-2449). This vulnerability occurs because the plugin uses native password reset functionality without sufficient validation, allowing an attacker to easily retrieve and use the plaintext value of a password reset key. This vulnerability can be exploited by leveraging other vulnerabilities like CVE-2023-2448 and CVE-2023-2446 or SQL Injection in other installed plugins or themes. The affected products include versions 'as-ue8', 'as-ue9', 'as-ue-', 'as-ue4', 'as-ue5', 'as-ue6', 'as-ue7', 'az_TGT', 'as-ue1', 'as-ue2', 'as-ue3', 'tzul99', and 'tzul9-' under the domain BIuvGo. With a base severity rating of CRITICAL and high impact on integrity and confidentiality, this vulnerability poses a significant danger to organizations using the UserPro plugin for WordPress. To remediate this vulnerability, users should update their UserPro plugin to a secure version that addresses this issue.

Explore Beyond the CVE Basics with Recorded Future's Vulnerability Intelligence

Note: This is just a basic overview providing quick insights into CVE-2023-2449 information. Gain full access to comprehensive CVE data, risk scores, prioritization, and mitigation data through Recorded Future's Vulnerability Intelligence:
  • Prioritize with Risk-Based Scoring
  • Explore the Extensive Vulnerability Database
  • Receive Early Alerts on Emerging CVEs
  • Focus on Critical Exploitable Vulnerabilities
  • Streamline Remediation with Integration Options